No se puede incluir “vendor / autoload.php” después de instalar Composer en Ubuntu

Me estoy familiarizando con los servidores Linux y estoy tratando de instalar Composer en mi servidor Ubuntu. Creo que todo está instalado correctamente, excepto cuando trato de incluir el autocargador de Composer obtengo un error de PHP:

Warning: require(/usr/share/php/opencloud/lib/../vendor/autoload.php): failed to open stream: No such file or directory in /usr/share/php/opencloud/lib/php-opencloud.php on line 5 Fatal error: require(): Failed opening required '/usr/share/php/opencloud/lib/../vendor/autoload.php' (include_path='.:/usr/share/php') in /usr/share/php/opencloud/lib/php-opencloud.php on line 5 

Mi composer.json es:

 { "require": { "rackspace/php-opencloud": "v1.7.0" } } 

Y cuando ejecuto “composer diag” produce esto:

 Checking composer.json: FAIL name : is missing and it is required description : is missing and it is required 

Este es un error existente con Composer en WINDOWS (para mí, al menos). Manual de instalación de estilo Composer.

vendor / autoload.php no se crea ni hay ningún otro contenido relacionado con autocarga.

Intento exactamente lo mismo en Linux Y Windows (excepto las diferentes opciones específicas de la plataforma en los comandos por lotes) para ejecutar Composer y para instalar / configurar rackspace usando Composer install & composer-rackspace require batch line. Obtengo 2 resultados diferentes. Las cosas relacionadas con Autoload se crean en Linux muy bien. No se crean cosas relacionadas con autocarga para Windows.

Guess Windows Composer necesita más trabajo / reparación. 🙁

Esto en general parece estar funcionando en Linux / Ubuntu para mí hasta ahora, te avisaré si tengo algún problema.

La advertencia parece ser bastante clara, no puede encontrar el archivo autoload.php. Supongo que algún problema de ruta requiere:

 require 'vendor/autoload.php'; 

Acerca de los datos faltantes que podría resolver agregándolo en su compositor.json

 { "name":"YOURNAME", "description":"YOUR DESCRIPTION", "require":{ "rackspace/php-opencloud": "v1.7.0" } }